Альфа в логотип - как вернуть пакет фильтров в GIMP 2.10?


 

Домой Дополнения для GIMP Общие вопросы по дополнениям для GIMP Альфа в логотип - как вернуть пакет фильтров в GIMP 2.10?
17 ответ(ов) в теме
Anykey
не в сети 3 месяца
На сайте с 24.09.2018
Участник
Тем 1
Сообщения 10
1
07:26

Запнулся на втором шаге:
"В меню выберите Фильтры - Альфа в логотип - Неон".
Нету в Фильтрах опции "Альфа в логотип". Всё перебрал - во всплывающих менюшках тоже не нашёл, возможно, переместили куда-то.
UPD нашёл в справке "найти и выполнить действие" - "Альфа в выделение" Но это не в Фильтры, это нужно ПКМ на слое в панели инструментов - и дальше опять затык, про неон там ничего нету.

Редакции сообщения
24.09.2018 07:34AnykeyПричина: не указано
24.09.2018 07:43AnykeyПричина: не указано
0
Админ "Уроки GIMP"
не в сети 10 часов
На сайте с 10.01.2017
Администратор
Тем 55
Сообщения 241
2
08:10

Здравствуйте.

Подскажите, какая версия GIMP у вас сейчас установлена?

0
Anykey
не в сети 3 месяца
На сайте с 24.09.2018
Участник
Тем 1
Сообщения 10
3
08:52

Подскажите, какая версия GIMP у вас сейчас установлена?

GIMP 2.10.6
OS Xubuntu 18.04 XFCE

Редакции сообщения
24.09.2018 08:53AnykeyПричина: не указано
0
Админ "Уроки GIMP"
не в сети 10 часов
На сайте с 10.01.2017
Администратор
Тем 55
Сообщения 241
4
08:57

В общем, если у вас какая-то из версий GIMP 2.10, то в неё нужно вручную добавить пакет скриптов Альфа в логотип. Поскольку разработчики удалили их между версиями 2.8 и 2.10.

Для этого скачайте пакет скриптов https://download.gimp.org/mirror/pub/gimp/extras/gimp-data-extras-2.0.4.tar.bz2

Затем последуйте руководству разработчиков:

Recently, we also revitalized an outdated subproject called ‘gimp-data-extras’ with the sole purpose of keeping the Alpha-to-Logo scripts that we removed from 2.10 due to poor graphics quality. Since some users miss those scripts, there is now a simple way to get them back: download gimp-data-extras v2.0.4, unpack the archive, and copy all ‘.scm’ files from the ‘scripts’ folder to your local GIMP’s ‘scripts’ folder.

Перевод:
Недавно мы также оживили устаревший подпроект под названием «gimp-data-extras» с единственной целью - сохранить скрипты Alpha-to-Logo, которые мы удалили из 2.10 из-за плохого качества графики. Поскольку некоторым пользователям нехватает этих сценариев, теперь есть простой способ вернуть их: загрузить gimp-data-extras v2.0.4 , распаковать архив и скопировать все файлы .scm из папки «scripts» в локальный каталог пользователя GIMP - папку "scripts".

Попробуйте. Останутся вопросы, обращайтесь.

0
Админ "Уроки GIMP"
не в сети 10 часов
На сайте с 10.01.2017
Администратор
Тем 55
Сообщения 241
5
11:02

Anykey сказал(а)

Подскажите, какая версия GIMP у вас сейчас установлена?

GIMP 2.10.6
OS Xubuntu 18.04 XFCE

Аа, тогда вам нужно следовать этому руководству:

If you are a Linux user, you should be able to install the package
following the usual ./configure && make && make install routine (you
can also ping gimp-data-extras packager of your Linux distribution to
update it).

0
Anykey
не в сети 3 месяца
На сайте с 24.09.2018
Участник
Тем 1
Сообщения 10
6
11:58

Спасибо за быстрый ответ, но...
Скачал, распаковал, файлы .scm в каталог /home/anykey/.gimp-2.8/scripts/ распаковал, перезапустил ГИМП - нету опции Фильтры - Альфа в логотип.
Пакет gimp-data-extras 1:2.0.2-1 в системе установлен.
Пытался установить пакет по install instructions в Install прямо из той папки, куда распаковал (в недрах системы), но система не увидела пакет ГИМП 2.0 в папке.
Распаковал в корень
anykey@anykey:~$ sudo ./configure
[sudo] password for anykey:
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for gimp... no
configure: error: Package requirements (gimp-2.0) were not met:

No package 'gimp-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables gimp_CFLAGS
and gimp_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
anykey@anykey:~$

- то же самое.
sudo не-sudo - без разницы.
Как победить? Может, скопировать файлы в каталог /usr/share/gimp/2.0/ и оттуда запускать?
Английский я знаю, перевода не требуется.

0
Anykey
не в сети 3 месяца
На сайте с 24.09.2018
Участник
Тем 1
Сообщения 10
7
11:59

anykey@anykey:~$ sudo ./configure && make && make install
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for gimp... no
configure: error: Package requirements (gimp-2.0) were not met:

No package 'gimp-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables gimp_CFLAGS
and gimp_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
anykey@anykey:~$

Редакции сообщения
24.09.2018 12:02AnykeyПричина: не указано
0
Админ "Уроки GIMP"
не в сети 10 часов
На сайте с 10.01.2017
Администратор
Тем 55
Сообщения 241
8
12:14

К сожалению с Линуксом я вам не помощник. Посмотрите внимательно эту статью https://mail.gnome.org/archives/gimp-user-list/2018-June/msg00076.html

В ней объяснялось, как вернуть эти фильтры обратно в программу. Может, я что-то упустил из-за незнания операционной системы Линукса?

Отпишитесь потом, пожалуйста, что в итоге у вас получилось. Ок?

0
Anykey
не в сети 3 месяца
На сайте с 24.09.2018
Участник
Тем 1
Сообщения 10
9
15:04

Всенепременнейше!

1
Anykey
не в сети 3 месяца
На сайте с 24.09.2018
Участник
Тем 1
Сообщения 10
10
15:49

Как я попытался скомпилировать пакет по этой инструкции https://help.ubuntu.ru/wiki/programs_installation
и как у меня ничего не вышло:

anykey@anykey:~/DELO_TECHNIKI/GIMP_extensions/gimp-data-extras-2.0.4$ aclocal
aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in'
anykey@anykey:~/DELO_TECHNIKI/GIMP_extensions/gimp-data-extras-2.0.4$ aclocal
aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in'
aclocal: warning: 'configure.ac' and 'configure.in' both present.
aclocal: proceeding with 'configure.ac'
configure.ac:594: warning: macro 'AM_BACKSLASH' not found in library
configure.ac:595: warning: macro 'AM_DEFAULT_VERBOSITY' not found in library
configure.ac:596: warning: macro 'AM_DEFAULT_V' not found in library
configure.ac:597: warning: macro 'AM_V' not found in library

Тут я взял и тупо переименовал configure.in в configure.ac (нешто я даром на Линуксе 9-й год сижу? Сила разума, ёпта!)

anykey@anykey:
~/DELO_TECHNIKI/GIMP_extensions/gimp-data-extras-2.0.4$ aclocal

И тишина. И мёртвые с косами стоят. Хм, подумал я и запустил следующую команду из инструкции

anykey@anykey:
~/DELO_TECHNIKI/GIMP_extensions/gimp-data-extras-2.0.4$ autoheader
autoheader: error: AC_CONFIG_HEADERS not found in configure.ac
anykey@anykey:~/DELO_TECHNIKI/GIMP_extensions/gimp-data-extras-2.0.4$ autoheader
autoheader: error: AC_CONFIG_HEADERS not found in configure.in
anykey@anykey:~/DELO_TECHNIKI/GIMP_extensions/gimp-data-extras-2.0.4$ automake --gnu --add-missing --copy --foreign
automake: warning: autoconf input should be named 'configure.ac', not 'configure.in'
automake: warning: autoconf input should be named 'configure.ac', not 'configure.in'
anykey@anykey:~/DELO_TECHNIKI/GIMP_extensions/gimp-data-extras-2.0.4$

В общем, обратился за поддержкой на losst.ru, вечно там всякие спасательные круги, авось и в этот раз помогут.

Редакции сообщения
24.09.2018 15:50AnykeyПричина: не указано
0
Anykey
не в сети 3 месяца
На сайте с 24.09.2018
Участник
Тем 1
Сообщения 10
11
16:01

Попытка переименовать в файле configure.in версию ГИМПа с 2.0 на 2.8 (в соответствии с названием папки .gimp-2.8)
anykey@anykey:~/DELO_TECHNIKI/GIMP_extensions/gimp-data-extras-2.0.4$ sudo nano configure.in

не была шибко удачной:

anykey@anykey:~/DELO_TECHNIKI/GIMP_extensions/gimp-data-extras-2.0.4$ sudo ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for gimp... no
configure: error: Package requirements (gimp-2.0) were not met:

No package 'gimp-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables gimp_CFLAGS
and gimp_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

0
Админ "Уроки GIMP"
не в сети 10 часов
На сайте с 10.01.2017
Администратор
Тем 55
Сообщения 241
12
23:54

Очень захватывающе :lol: Так чем всё закончилось? Вы вернули фильтры Альфа в логотип на Линукс?

0
Anykey
не в сети 3 месяца
На сайте с 24.09.2018
Участник
Тем 1
Сообщения 10
13
01:02

Не, ничего не получилось. Закончилось тем, что я переключился на другие уроки. На всё обозримое будущее мне хватит учебных задач, а уж когда доберусь до неонового логотипа - который не есть нечто 'must have' для умеющего в ГИМП и под который, вообще говоря, задач нет и не предвидится - авось и обновление подтянется.
Хотя "эффект Зейгарник" во всей красе имеет место быть; так что пару дней подожду ответа с losst.ru, потом на другие линуксовые коммьюнити пойду.
Но, скорее всего, проще всего дождаться обновлений репозиториев Убунты, когда нужный пакет будет включён в основной состав пакетов. Произойдёт же это когда-нибудь.
(не учиться же мне пакеты компилировать!%)))

1
Anykey
не в сети 3 месяца
На сайте с 24.09.2018
Участник
Тем 1
Сообщения 10
14
13:03

РЕШЕНО:
Вот это: "Download gimp-data-extras v2.0.4, unpack the archive, and copy all ‘.scm’ files from the ‘scripts’ folder to your local GIMP’s ‘scripts’ folder."
- оказалось подставой))).
Не в локальный каталог, в в /usr/share/gimp/2.0/scripts
Правильная инструкция была вот здесь:
https://www.opennet.ru/opennews/art.shtml?num=48913 «В gimp-data-extras вынесены скрипты Alpha-to-Logo, которые не были включены в ветку 2.10 из-за ненадлежащего качества графики (для установки скриптов достаточно скопировать файлы ».scm" из архива в каталог scripts GIMP)." - и разница, по сути, была всего в одном слове: "локальная" (папка). поскольку скрипты переносить нужно было не в папку пользователя (что ничего не давало), а в /usr/share/gimp/2.0/scripts.
Вот и сказочке конец, а кто слушал - молодец!
Спасибо за внимание и попытки помочь.

Редакции сообщения
25.09.2018 13:24AnykeyПричина: не указано
25.09.2018 13:26AnykeyПричина: не указано
25.09.2018 13:26AnykeyПричина: не указано
0
prokoudine
не в сети 2 месяца
На сайте с 25.09.2018
Участник
Сообщения 5
15
13:29

Пришлось зарегистрироваться даже.

Не надо выдумывать: скрипты прекрасно подхватываются из локальной папки.

Вы их просто запихнули в какой-нибудь ~/.gimp-2.8/scripts, а надо было в ~/.config/GIMP/2.10/scripts.

0
Anykey
не в сети 3 месяца
На сайте с 24.09.2018
Участник
Тем 1
Сообщения 10
16
13:58

Ну да, именно так и было. А что иное может означать "скопировать все файлы .scm из папки «scripts» в локальный каталог пользователя GIMP - папку "scripts"? Про .config/GIMP/2.10/scripts там (и вообще во всех инструкциях, перерытых за эти дни) ничего не было сказано, откуда бы мне знать?
ОК, скопирую и туда тоже - хоть перенесутся при бэкапе.

Редакции сообщения
25.09.2018 13:59AnykeyПричина: не указано
0
prokoudine
не в сети 2 месяца
На сайте с 25.09.2018
Участник
Сообщения 5
17
13:27

Anykey сказал(а)
Ну да, именно так и было. А что иное может означать "скопировать все файлы .scm из папки «scripts» в локальный каталог пользователя GIMP - папку "scripts"? Про .config/GIMP/2.10/scripts там (и вообще во всех инструкциях, перерытых за эти дни) ничего не было сказано, откуда бы мне знать?

Т.е. вы хотите сказать, что у вас версия 2.10, но вы считаете логичным закинуть скрипты в папку версии 2.8 и ждёте, что всё заработает? :)

Напоминаю, что локальные папки для текущей версии всегда можно подсмотреть в диалоге настройки. Например, для скриптов это будет 'Edit > Preferences > Folders > Scripts'. В этом же разделе настроек (Folders) можно добавить свои папки со скриптами, кистями и прочим — в соответствующих подразделах.

Что касается сборки gimp-data-extras, несмотря на то, что компилировать там нечего, скрипту установки нужен пакет с заголовочными файлами. В убунте это будет что-то типа libgimp2.0-dev.

Редакции сообщения
28.09.2018 13:28prokoudineПричина: не указано
28.09.2018 13:30prokoudineПричина: не указано
1
Вы не имеете права на публикацию сообщений в этой теме

Форум GIMP для начинающих и профи https://uroki-gimp.ru/forum


Таллиннское шоссе, дом 20 20304 Эстония, Нарва +37253010126
Авторизация
*
*
Регистрация
*
*
*
Укажите свой уровень освоения GIMP
Генерация пароля